https://garden.io logo
#🌱|help-and-getting-started
Running service interactively no longer works as specified in docs
# 🌱|help-and-getting-started
k

kind-carpet-47197

02/09/2023, 8:57 AM
Hi! I'm new to garden and just set up my first project to try it out. Read the following line in the docs (https://docs.garden.io/using-garden/using-the-cli#running-a-single-ad-hoc-service-and-attaching) . *Running a single ad-hoc service and attaching: `garden run service my-service --interactive # or -i for short`*. However this command fails and the CLI no longer lists
--interactive
as an option for the command
garden run service
. Is there a new way of running a service interactively that hasn't been documented yet?
b

bright-policeman-43626

02/09/2023, 3:52 PM
Hello there! @kind-carpet-47197 would you mind sharing your garden version please!
What happens if you run it without the --interactive? It seems like that option has been removed from that command. Definitely we will need to remove it from the documentation. Do you mind explaining a little bit what do you want to achieve with this new Garden setup? I wouldn't mind giving you a hand on some tips & tricks to make it work! Welcome to Garden🌸
k

kind-carpet-47197

02/10/2023, 1:59 PM
Thanks @bright-policeman-43626! The immediate challenge I'm facing is running a test suite from within a container and being able to interact with it through the command line. I'm using jest (and vitest) in interactive watch mode and if I start it locally I can e.g. press enter to rerun or 'h' to show help. When starting the same tests using garden stdin doesn't reach it, even though I've set
tty: true
Could this be a
local-kubernetes
issue? I'm trying this out on docker-for-desktop
b

bright-policeman-43626

02/10/2023, 3:08 PM
I just checked locally and maybe instead you can try to add a tests: block? Then you can run garden run test api jest —interactive
Seems like this is the one you could use
2 Views