fix(cloud): ensure cloud project id is s...
# 💻|contributing
I notice the e2e tests for keep failing with
RequestError: getaddrinfo ENOTFOUND
AFACIT this also happens on main and is not related to my changes. I'm not super hip to the changes we've been making around the e2e tests though. Anything silly I'm missing here? Is that address supposed to actually exist?
Hmm, the integ test case that references this looks like it was designed to not ping this URL. The logic that's being tested checks whether there's a Cloud API instance on the plugin context when deciding whether to add / check for the AEC annotation on the Helm charts being deployed / checked. Maybe something's changed in the init flow around the Cloud API since then that's pinging the URL, where that didn't happen in the past?
There's a chance my code broke it. I tried on main and got the same error though. There's also a chance that happened because the compiler stopped building. I've been seeing that quite often recently and have to frequently restart it. So I'll give it another spin on my end.
BTW, the CI has been green within the last few days on the main branch:
Did you try the test locally on the main branch?
Yes, I did and I got the same error. But I'll double check.