How to support Docker mount type ssh

I’m using the local docker build process for my local environment and an issue that I’m seeing is that some of our images require ‘–mount=type=ssh’ when executing this process locally by directly building the docker image works, but running the build through garden it fails. I’ve added additional logging to see if the image is actually get the SSH token and it doesn’t appear to be passed in. Does Garden.io support this, is there something special I need to be doing to the local-kubernetes provider to enable something like this?

Hi @djowinz!

Apologies for the late reply, this one kind of slipped through the tracks.

My first suggestion would be to pass the --ssh flag to Docker. You can do that via the extraFlags field on the container module type.

Can you try and see if that helps?