Garden 0.12.23 failed to extract

Hi,

We upgraded to use the latest release of garden 0.12.23 and received the following error:

→ Downloading https://github.com/garden-io/garden/releases/download/0.12.23/garden-0.12.23-linux-amd64.tar.gz...
→ Extracting to /home/runner/.garden/bin...

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now

It seems the reason is inconsitency in the download path.
https://get.garden.io/install.sh looks in:
Downloading https://github.com/garden-io/garden/releases/download/0.12.23/garden-0.12.23-linux-amd64.tar.gz
while it has to look in:
Downloading https://github.com/garden-io/garden/releases/download/0.12.23-0/garden-0.12.23-linux-amd64.tar.gz.

I tried both:

curl -sL https://get.garden.io/install.sh | bash -s 0.12.23

and

curl -sL https://get.garden.io/install.sh | bash -s 0.12.23-0

Can someone please let me know how to fix this?

TL;DR: This works now.

Hmm, that is a little odd. The script is trying to download a pre-release of Garden. The latest release is 0.12.22, but we’re planning on releasing 0.12.23 this week.

By best guess is that the pre-release was flagged as an actual release for a brief moment on GitHub and that you tried downloading Garden at that point. In any case, it’s no longer flagged as such and the script should just work. It’ll download 0.12.22 if you try it out, but again, 0.12.23 should be up very soon.

That’s right @Eysi . We decided to force downloading the pre-release by piping bash -s 0.12.23-0. Our reason was the failure of garden after the new git release and making some flags mandatory. Our assumption was that the new pre-release has adopted the git update.

I think now we will be waiting for the next release of garden.

Thanks for your answer.

In case you missed it, we’ve addressed the git issue in our latest release.