Garden is hanging on most commands
# 🌱|help-and-getting-started
I have updated garden to 0.13.23 on a M1 Mac. All commands (i.e.
garden validate
garden deploy
garden dev
) are hanging on "*Running in environment*" I cannot see any meaningful information in the logs. Can I get some assistance please?
Hi all, I have resolved the issue by tightining up my
file to be more strict, and removing the usage of
entirely from the project configuration.
Which version were you running previously? Also did the performance get impacted also in other ways?
Hey @polite-fountain-28010 , I was running version 12 previously - can't recall the exact version. I feel like the performance was impacted significantly. From a user experience, the "*Running in environment...*" message looked like it was "frozen" to me, I think some form of loading indicator that occurs elsewhere in the CLI could be beneficial - if that makes sense. We have quite a large monorepo. Does garden have a command to see what files are being scanned? Could help with crafting a
file. As an example, some frontend developers were building multiple
projects which create a lot of output files. This impacted garden's performance since we didn't update the .
file, yet those frontend developers weren't using garden in their workflow so they are unaware of the impact. Could your cloud solution include a feature where is monitors the size of scanned files? If it increases above a certain threshold, users could be notified (i.e. you aren't excluding
build outputs as was our case). Also, the
file seems to speed up the process tremendously compared to configuring includes/excludes in the project definition - wondering if it is worth notifying users about this through the CLI somehow? Not sure, just giving generic feedback/ramblings as a user. If I was evaluating garden for usage in a large codebase/monorepo and performance was poor "out the box" with no immediate suggestions, one might pass over it pretty quickly. But just to clarify I love garden and think it is a complete game changer - we couldn't live without it.
That's all great feedback, thanks a lot! The CLI should already notify you if there are too many scanned files and suggest configuring an ignore file or changing the includes and excludes. If it hasn't done that for you, I wonder if there's something else going on. If you're running garden with
as an argument to enable more detailed logs, you should see the amount of files that it had to scan and filter down. By the way, is 0.13.23 the first 0.13 version you updated to from 0.12 and did you use
to update to it? We released a build that supports M1 macs natively a while back, but the self updater from 0.12 isn't aware of it and won't install it. In that case I'd suggest to run
garden self-update --force
once again so that the 0.13 self updater can install the correct M1 version. That should also bring a solid performance boost.
After you made sure you're on the ARM build, if the performance is still bad, I'd love to see the output of
garden validate -l4 --show-timestamps
so we can take a look at exactly what's slow when it's running.
Hey @curved-farmer-35040, have you had a chance to check whether you were running with the M1 build of garden? I'd be curious to see if that at least partly addresses your performance concerns.
Hi @curved-farmer-35040 I wanted to check back in to be sure if this was resolved for you ❔
Hi @quaint-dress-831 apologies, I don't have discord notifications disabled on my work machine so I missed this. Yes, I ways always running the M1 build of garden. The issue was just a poor config on my part!