https://garden.io logo
#πŸ’»ο½œdev
Looks like I ran out of Kubernetes (
# πŸ’»ο½œdev
b

brief-restaurant-63679

12/10/2023, 9:04 PM
Looks like I ran out of Kubernetes (ephemeral clusters that is) but the error message isn't very helpful:
Copy code
β„Ή providers                 β†’ [kubernetes] Waiting for resources to be ready...
β„Ή providers                 β†’ [kubernetes] Deployment/default-backend: Waiting for rollout: 0 out of 1 new replicas updated...
⚠ providers                 β†’ [kubernetes] Deployment/default-backend: Failed to create pod sandbox: rpc error: code = Unknown desc = failed to setup network for sandbox "4dabd82e93f4ced89f660526f973eb846c4c40f182ae572593bc395cbc41391d": plugin type="flannel" failed (add): open /run/flannel/subnet.env: no such file or directory
βœ– providers                 β†’ Failed processing resolve provider ephemeral-kubernetes (took 30.9 sec). This is what happened:

──────────────────────────────────────────────────────────────────────────────────────────────────────────────────
Timed out waiting for providers to deploy after 20 seconds
──────────────────────────────────────────────────────────────────────────────────────────────────────────────────
Failed resolving one or more providers:
- ephemeral-kubernetes

See .garden/error.log for detailed error message
I can create a GitHub issue but just wanted to check first whether this was known a issue? Or for that matter something unrelated to me being out of minutes?
a

astonishing-tomato-18259

12/11/2023, 10:24 AM
Did you run into it while creating a cluster? The message should be the error from he API around the lines "Unable to create ephemeral cluster. Your monthly allowed quota has been exhausted" with status code 429, in case your ephemeral clusters quota is exhausted. And core is supposed to show the error message received from API in that case. https://github.com/garden-io/garden/blob/main/core/src/cloud/api.ts#L836
b

brief-restaurant-63679

12/11/2023, 11:07 AM
Ok thanks, I'll take another look
2 Views