https://garden.io logo
#💻|dev
Garden telemetry bug
# 💻|dev
b

breezy-queen-93424

12/04/2023, 8:24 AM
Hi folks, very new to Garden as I am onboarding as a Platform Engineer at a new org. I wanted to get started with Garden as it is widely used here for deployments. However I immediately ran into issues after installing the cli via homebrew. Whenever I ran any command, I ran into an issue where the command invocation crashed abruptly due to an error with an api call to segment. I then disabled the telemetry and the issue no longer persisted. I am now able to use garden cli. I am attaching the error log that appeared on the console after any garden command. Is this a known issue at the moment? I was not able to find any open issues on github about the same. Also I can conform that the endpoint api.segment.io is not blocked where I am ( used multiple VPNs and still the same error, unless telemetry was disabled ). Thought I would report this here first. https://cdn.discordapp.com/attachments/1088795679159222292/1181148938242371635/error.log?ex=658001ab&is=656d8cab&hm=6809cf0970414069669d5dfdddea6ec03a2b6cf4253549e3c0e22631cd279eab&
q

quaint-dress-831

12/04/2023, 9:25 AM
Hi @breezy-queen-93424 and welcome to the community! 👋 I've opened a DM with you and escalated your issue internally. Either I or another engineer will return to you shortly 🧑‍🔧
c

chilly-gigabyte-83853

12/04/2023, 9:26 AM
Hey there, we were literally discussing this 2' ago. 🙂 It looks like a bug that might be related to a bump on a dependency. We are investigating and we'll work on a fix soon! Sorry about that.
b

breezy-queen-93424

12/04/2023, 9:43 AM
No worries at all, I am happy to help where ever I can. Maybe this is a good start for me to get more involved with the community here. :). Let me know if I can help with something.
Hello folks, is there a Github issue already that I can track?
c

cold-jordan-68753

12/06/2023, 8:32 AM
Hi, we fixed this issue here, https://github.com/garden-io/garden/pull/5505. You can try it out already with
garden self-update edge-bonsai
or wait for the next release.
b

breezy-queen-93424

12/11/2023, 9:40 AM
Awesome, thanks a lot. I will gladly wait for the next release. Cheers.
b

big-spring-14945

12/14/2023, 4:02 PM
@breezy-queen-93424 this has been released recently in 0.13.22