https://garden.io logo
#🌱|help-and-getting-started
Action includes broken from changes in tracked git files
# 🌱|help-and-getting-started
o

orange-ability-1812

08/25/2023, 8:43 PM
I'm having a hard time understanding and reproducing this issue, but I thought I would reach out for tips and to see if anyone else had experienced this. Occasionally garden will fail in container Build actions because it fails to include files for the build context. I've triple checked my
.gardenignore
and my
include
section and there is no doubt that they are included. And indeed the same configuration works at other times. Its always the same files interestingly
Makefile
, and e.g.
dev/containers/tests.Dockerfile
. I've tried renaming the files, clearing the cache and build envs, running with
garden --force-refresh build thing --force
, nuking the entire project
.garden
directory, reinstalling garden and nuking
~/.garden
and nothing seems to work except waiting (usually the next day...). The last bit makes me think that there is something wrong with timestamp checking or something. This is pretty breaking and basically halts my work until garden decides to fix itself. Any ideas at all?
I've learned a little bit. It is caused by some inconsistency with the current state of git wrt staging files. After a commit the problem is resolved.
q

quaint-dress-831

08/28/2023, 11:57 AM
@orange-ability-1812 so this is only an issue when files aren't committed? I can't say I've experienced failing builds based on their commit status. If so, this sounds like a bug.
o

orange-ability-1812

08/28/2023, 12:46 PM
Not exactly. I made changes to an already tracked file and then this happened. Although there has to be more to it as I do that all the time and it doesn't break.
I'm now experiencing something similar with deploys. So I think it has to do with the includes logic itself. @quaint-dress-831 Is there a way for me to see what is included in my actions exactly?
q

quaint-dress-831

08/30/2023, 9:03 AM
@orange-ability-1812 if you dive into your
.garden
directory you can see what files get sourced into any given action context. I've done this often to check if I've missed a file or dragged a file in by mistake.
o

orange-ability-1812

08/30/2023, 3:07 PM
I can see the files that are put into the action sandbox and thats how I was able to diagnose the issue. I guess what I'm asking is to see why a certain file didn't make it in. If I run with
-l5
I can see a bunch of
git ls-files
commands being run and I guess I'd need to dig into those or something similar.
q

quaint-dress-831

08/30/2023, 3:09 PM
@chilly-gigabyte-83853 would you know the answer to this?
c

chilly-gigabyte-83853

08/31/2023, 4:06 PM
Hi @orange-ability-1812, sorry for the late reply. I don't think we show in the logs which files are included or not, unfortunately. But we could try to debug this if you had a repro. Is this project you are working on something you could redact and share or does it happen also in some of our example projects? Which operating system are you running on?
o

orange-ability-1812

08/31/2023, 5:01 PM
I'm on OpenSUSE Tumbleweed. I can try to set up an isolated repro now that I have a better idea of what causes it, and planned to do so when I had the time. I'll just open an issue on Github at that point.
q

quaint-dress-831

09/01/2023, 1:03 PM
@orange-ability-1812 🎉 openSUSE 🦎 Happy to discover more Linux users out there using Garden 🧑‍🌾
o

orange-ability-1812

09/01/2023, 1:12 PM
Lol I was Ubuntu for a long time but wanted a rolling release that wasn't bleeding edge like arch
q

quaint-dress-831

09/01/2023, 4:14 PM
Curious what your thoughts are on https://microos.opensuse.org/
o

orange-ability-1812

09/03/2023, 4:40 PM
I actually don't know much about that one.
3 Views