https://garden.io logo
#🌱|help-and-getting-started
quickstart issue on windows
# 🌱|help-and-getting-started
a

abundant-architect-46258

08/19/2023, 4:10 PM
I was trying the quickstart(https://docs.garden.io/basics/quickstart) on bonsai/windows with docker-desktop and running into this issue running deploy. Any ideas here?

https://cdn.discordapp.com/attachments/1142490733975179325/1142490734453346414/image.png

q

quaint-dress-831

08/21/2023, 3:55 PM
@abundant-architect-46258 hi kroher! Let me give the quickstart a spin on Windows and get back to you 🚜 🧑‍🌾
Sorry for the delay, @abundant-architect-46258, I run Linux on my work machine and needed to lend my wife's Windows laptop to test. I can confirm that running the latest 0.13.12 release of
garden
works on her machine on Docker Desktop using Docker Desktop's built-in Kubernetes cluster
I tried both with 0.13.8 and 0.13.12 and experienced the same result
I would try and
git pull
the latest
quickstart-example
to ensure any odd string interpolation issues have been fixed
The output of
git status
in that repo would also be helpful
a

abundant-architect-46258

08/23/2023, 3:03 AM
Thanks for checking it out! I ended up trying a few things and it ended up that I needed to delete my user .garden directory, then re-install garden. I'm now into some other strange thing where the build is seemingly creating some inaccessable directories/files that I cant remove when I turn things off and reboot. api-build, result, vote, worker are all in this state in the build directory. The errors during build in garden deploy are like this:
Copy code
Unable to run docker command: Command "C:\Users\kroher\.garden\tools\docker\5a0bc93c8664c344\docker\docker.exe build -t vote:v-9c69374b3b --build-arg GARDEN_MODULE_VERSION=v-9c69374b3b --build-arg GARDEN_ACTION_VERSION=v-9c69374b3b --file C:\Users\kroher\code\garden\quickstart-example-4\.garden\build\vote\Dockerfile C:\Users\kroher\code\garden\quickstart-example-4\.garden\build\vote" failed with code 1:

#0 building with "default" instance using docker driver

#1 [internal] load .dockerignore
#1 transferring context: 2B done
#1 DONE 0.1s

#2 [internal] load build definition from Dockerfile
#2 transferring dockerfile: 2B done
#2 DONE 0.1s
ERROR: failed to solve: failed to read dockerfile: open /var/lib/docker/tmp/buildkit-mount2210432570/Dockerfile: no such file or directory
q

quaint-dress-831

08/23/2023, 8:20 AM
Hmmm 🤔 can you try and run
garden deploy -l5
and post the logs to a Gist?
Have you tried purging data from the bug icon in Docker Desktop?

https://cdn.discordapp.com/attachments/1142490733975179325/1143822652918734879/6QbgO.png

a

abundant-architect-46258

08/24/2023, 4:03 PM
I believe that was one of the things I tried in addition to factory resetting docker and a clean checkout. I'll give it a re-try though as well as get some log details when I find some time in the next few days.
q

quaint-dress-831

08/31/2023, 3:03 PM
@abundant-architect-46258 setting this to resolved: please let us know if you encoutner any more trouble 😺
a

abundant-architect-46258

09/04/2023, 2:53 PM
I ended up getting it working, i think something was up with how i had docker-desktop installed (through chocolatey which i also had to install kind for it to work), uninstalled those, and did a standard docker-desktop install and things worked. I still have some undeletable
.garden/build/
directories from whatever weird state things were in, probably from orphaned installs/docker resets or something that clean/purge aren't hitting somehow. Anyway thanks again!
2 Views