https://garden.io logo
#💻|dev
ingress issues in CI
# 💻|dev
a

ancient-diamond-80011

03/30/2023, 11:56 AM
a bunch of our VM tests have been failing in CI recently
i was creating this PR to see if changing the hostnames from possibly-registered valid ones to invalid ones would change anything https://github.com/garden-io/garden/pull/4029 but it's unrelated - the tests were failing before and are failing after
ah, these tests were not enabled before https://github.com/garden-io/garden/pull/4009
a

alert-helicopter-61082

03/30/2023, 12:10 PM
Didn't @calm-family-29323 already post a fix PR?
a

ancient-diamond-80011

03/30/2023, 12:11 PM
c

calm-family-29323

03/30/2023, 12:18 PM
@alert-helicopter-61082 can I merge that fix or will you look into a more clean way of fixing the issue?
a

ancient-diamond-80011

03/31/2023, 8:11 AM
@calm-family-29323 i'm tempted to say let's just merge it to get our CI back to green, we can always make another followup PR where needed
c

calm-family-29323

03/31/2023, 8:46 AM
okidoki
@alert-helicopter-61082 I get this on platform now
Copy code
✖ Validation error(s) when reading configuration file at /Users/orz/work/garden-platform/.garden/local-config.json:
|-
  [
    {
      "code": "invalid_type",
      "expected": "string",
      "received": "undefined",
      "path": [
        "defaultEnv"
      ],
      "message": "Required"
    }
  ]
I'm also unable to set a default env via the command (get the same error) Fixed it for myself by manually adding the
defaultEnv
entry to the file.
a

alert-helicopter-61082

03/31/2023, 9:09 AM
Yeah, we need a default empty string value there in the local config schema. Could you fix that?
c

calm-family-29323

03/31/2023, 9:09 AM
sure
oh this was an unrelated thread, my bad
a

ancient-diamond-80011

03/31/2023, 10:47 AM
bah. the tests passed on your PR, but now on 0.13 the VM tests are failing with timeouts. related or not? 🤔
c

calm-family-29323

03/31/2023, 10:47 AM
these integ tests are making me feel strong feelings
I think it's the same imagePull issue
a

alert-helicopter-61082

04/03/2023, 9:07 PM
Those same tests are also failing from my machine directly
Actually, more specifically, they fail on the first run, not the second. So basically they don't work on a clean cluster.
We really need to fix these integ tests... We're back to "no clue whether I broke something in my PR" territory here.
c

calm-family-29323

04/04/2023, 12:57 PM
I can have another go at it, but I've failed to reproduce the issue locally even on a reset cluster, deleted images, cleared cache, etc. Also had Anna run these on her laptop and they passed just fine. I'd appreciate a higher log level output if you can still reproduce it on your machine. If not I'll just try to reproduce it again or debug in the ci.
a

alert-helicopter-61082

04/04/2023, 4:40 PM
I suspect it's all the same issue somehow... Maybe changing the integ tests to log aggressively and break after first failure would be good.