Completely uninstall garden.io
# 🌱|help-and-getting-started
e
Hey all, how do I uninstall garden.io completely on MacOS? Simply running
brew remove garden-cli
still leaves garden running (tried going to http://localhost/something and got the garden 404 page still that says it's running)
b
Hey! I hope this is just a matter of cleaning up/housekeeping rather than leaving Garden? If you are, would you mind sharing some of the reasons why are you stop using Garden? With that said; The page that it's displaying the 404 is NGINX deployed in your Kubernetes cluster. Usually to cleanup all of that you can do: - garden delete environment - garden delete namespace Check if the
garden-system
namespace is still there, if it is; force it's deletion:
kubectl delete ns garden-system --force
And then you can run
brew remove garden-cli
which will remove the binary.
e
Thanks @bright-policeman-43626. I ran
garden plugins local-kubernetes uninstall-garden-services
and that seems to have worked also (at least for getting rid of the nginx stuff installed on local k8s). No, I'm not leaving, just starting actually, but I was doing some other proxy work and garden was interfering, so wanted to remove it for now.
b
Great! I'm glad; welcome to Garden's Community; we are here to help you and make your experience with Garden the best! If you have any other questions, don't hesitate to reach out!
198 Views